Opened 7 months ago

Closed 7 months ago

#1349 closed enhancement (fixed)

Updates to registration of specimen handled by external lab

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.33.5
Component: net.sf.basedb.reggie Keywords:
Cc:

Description (last modified by Nicklas Nordborg)

See #1347 and #1295 for background.

More changes that are needed before we can implement registration from case.

  • Qiacube position: is now specified like 1:A. We need to implement support for this format. Most likely the range is 1-6 and A-B but this need to be confirmed.
  • Qiacube run number: is now specified as a plate identifier (eg 12-345678). We should be able to use this together with the date information to be able to assign a run number.
  • RIN: The RNA section now has a RIN value. We need to create the proper RNAQC item for this. There is no plate information so we need to check that this doesn't affect other things. Most importantly we need to make sure that the algorithm for finding RNAQC(last) works.
  • More... ?

UPDATE We decided that it might be easier to change the order in which things are registered. The data import from the JSON file should be done before the referral form registration. This is more similar to what can already be done today when the lab receives a specimen but there is a delay before the referral form is registered. Downstream wizards should already work. One exception is the Genotype QC wizard that require patient information, but this case should already be supported in the sense that this wizard will wait until the referral form has been registered.

Another exception might be the case where two specimen tubes are sent with a single referral form. It may happen that data for one specimen is transferred some time before the second one. If the referral for is registered after we got data for the first specimen we must make sure that the data import for the second specimen is connected correctly (this is a case that is not supported today).

NOTE! This means that we don't need the FutureSpecimen item type any longer.

Change History (23)

comment:1 Changed 7 months ago by Nicklas Nordborg

In 6480:

References #1349: Updates to registration of specimen handled by external lab

Implemented support for Qiacube positions in "1:A" format.

comment:2 Changed 7 months ago by Nicklas Nordborg

In 6481:

References #1349: Updates to registration of specimen handled by external lab

Implemented support for generating a "Qiacube run number". The information in the RNA section is used for this. It works by finding existing RNA items with the same QiacubeDate. There is an error condition if another RNA with the same QiacubeRunId (a new annotation) and position if found. Otherwise we re-use an existing run number or calculate a new one.

DNA and FlowThrough items should have the same run id and position as the RNA. If not an error is generated, otherwise the run number is copied from the RNA.

comment:3 Changed 7 months ago by Nicklas Nordborg

In 6482:

References #1349: Updates to registration of specimen handled by external lab

RIN values are now imported as RNAQC items. There is no explict date or plate information for this. We re-use the extraction date from the RNA item and there is already support for RNAQC items without plate inforamtion in Reggie (if this doesn't work it should be considered as a separate bug).

For now, we assume that RIN values are between 0 and 10 since we don't know if CMD has implemented any of the special values that we have used when there is an issue with the QC estimate.

comment:4 Changed 7 months ago by Nicklas Nordborg

In 6483:

References #1349: Updates to registration of specimen handled by external lab

Adding some more properties for the specimen section.

comment:5 Changed 7 months ago by Nicklas Nordborg

Description: modified (diff)
Status: newaccepted

comment:6 Changed 7 months ago by Nicklas Nordborg

Description: modified (diff)

comment:7 Changed 7 months ago by Nicklas Nordborg

In 6485:

References #1349: Updates to registration of specimen handled by external lab

Import Clarity ID to the ExternalRef annotation on Specimen items. With this information we can split the counter added in [6484] into two. One counter for local specimen and one counter for external specimen.

Also fixed an issue with the QiacubeRunID annotation that was installed incorrectly.

comment:8 Changed 7 months ago by Nicklas Nordborg

In 6490:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen from Case summary.

comment:9 Changed 7 months ago by Nicklas Nordborg

In 6491:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen from Retraction wizards.

comment:10 Changed 7 months ago by Nicklas Nordborg

In 6492:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen from import and export wizards.

comment:11 Changed 7 months ago by Nicklas Nordborg

In 6493:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen Linked specimen, Reference date and some other wizards that just query the variants of Specimen/NoSpecimen/FutureSpecimen?

comment:12 Changed 7 months ago by Nicklas Nordborg

In 6494:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen from installation and counter.

comment:13 Changed 7 months ago by Nicklas Nordborg

In 6495:

References #1349: Updates to registration of specimen handled by external lab

Re-organized the importer so that it should be able to create new specimen items instead of using pre-registered FutureSpecimen items.

comment:14 Changed 7 months ago by Nicklas Nordborg

In 6496:

References #1349: Updates to registration of specimen handled by external lab

Verify that a consent is not blocking registration.

comment:15 Changed 7 months ago by Nicklas Nordborg

In 6498:

References #1349: Updates to registration of specimen handled by external lab

Renamed FutureSpecimenImporter and FutureSpecimenServlet to ExternalSpecimenImporter and ExternalSpecimenServlet

comment:16 Changed 7 months ago by Nicklas Nordborg

In 6499:

References #1349: Updates to registration of specimen handled by external lab

Removed FutureSpecimen.

comment:17 Changed 7 months ago by Nicklas Nordborg

In 6500:

References #1349: Updates to registration of specimen handled by external lab

Added most (all?) of the missing properties that we are expecting to find in the JSON file. Warning messages are used instead of error messages so that it should be possible to import the data. It has not been tested with other wizards that may rely on the missing information. It is not known what will happen in those cases.

comment:18 Changed 7 months ago by Nicklas Nordborg

In 6501:

References #1349: Updates to registration of specimen handled by external lab

Added most (all?) of the missing properties that we are expecting to find in the JSON file. Warning messages are used instead of error messages so that it should be possible to import the data. It has not been tested with other wizards that may rely on the missing information. It is not known what will happen in those cases.

comment:19 Changed 7 months ago by Nicklas Nordborg

In 6502:

References #1349: Updates to registration of specimen handled by external lab

Allow 'C' and 'D' suffixes in the case name and automatically set "Biopsy type" to "SpecimenCoreBiopsy?" or "SpecimenCoreBiopsy2nd".

comment:20 Changed 7 months ago by Nicklas Nordborg

In 6503:

References #1349: Updates to registration of specimen handled by external lab

Add a prefix 'cmd:' to all protocol names.

comment:21 Changed 7 months ago by Nicklas Nordborg

In 6504:

References #1349: Updates to registration of specimen handled by external lab

Implement a toggle fow showing/hiding warnings if there are more than 6. This should make the table easier to read in case there are a lot of warnings.

comment:22 Changed 7 months ago by Nicklas Nordborg

In 6505:

References #1349: Updates to registration of specimen handled by external lab

Display the current case and a link to the case summary (in a popup window) if a case already exists.

comment:23 Changed 7 months ago by Nicklas Nordborg

Resolution: fixed
Status: acceptedclosed

Closing this in preparation for a release. It should now be possible to perform an import even if a lot of information is missing in the JSON files. Secondary analysis should work as expected, but some other wizards may have issues with the missing information. This need to be addressed when we discover them. The best is if we can manually add the missing information, otherwise the wizards need to be updated.

Note: See TracTickets for help on using tickets.