Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#1196 closed defect (fixed)

Incorrect specifications in the mRNA protocol

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v4.24
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

After extract an RNA comes out with concentration <10ng/µl, which means that all 50µl are needed to be within the protocol limits (100-500ng). Example:

NDConc: 7.159 ng/µl
Volume: 50 µl
Original quantity: 0.358 µg

The pre-normalization wizard handles this case correctly and says that all of the RNA should be used an no water should be added.

The mRNA plate design wizard simply shows that the item is a PreNormalized item and doesn't show any mixing instruction (as it is expected to do) and registration is successful.

However, when the mRNA lab protocol is displayed there is a warning message about "Not enough RNA" and it says that 69.9 µl should be used. In the database it has also been registered that the mRNA item uses 50µg from the pre-normalized item, leaving it with a remaining quantity of -0.142µg.

So for some reason it seems like the mRNA plate design wizard has registered that 50µg should be used even though there is only 0.36µg to use.

This started on 2019-09-17 and there are currently 5 pre-normalized RNA items with NDConc<10 in the database with a negative remaining quantity. There are more than a 1000 items before 2019-09-17 with NDConc<10 and they all have 0 remaining quantity.

It seems very likely that this problem was caused by Reggie 4.23 which was installed on the server 2019-09-16.

Change History (4)

comment:1 Changed 3 years ago by Nicklas Nordborg

Milestone: Reggie v4.xReggie v4.23.3

comment:2 Changed 3 years ago by Nicklas Nordborg

I think we have to blame #1165 and [5552] where the select_rna.js file was modified so that an if (... && !rna.external && ...) statement was modified to if (... && info.bioWell && ...).

This causes a lot of calculations and output to be skipped if an item doesn't have a location on a bioplate. Pre-normalized RNA items doesn't have this so that is why the calculations never took place and the used quantity was then simply taken from the TargetAmount value from the selected protocol.

comment:3 Changed 3 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 5675:

Fixes #1196: Incorrect specifications in the mRNA protocol

Removed the check for info.bioWell. The reason it was inserted to begin with is a bit unclear but most likely was to avoid a lot of warnings if the generic "External" RNA item was selected in the wizard. Since pre-normalized item doesn't have a bioplate location, a side-effect was that the section for calculating the used quantity was skipped.

comment:4 Changed 2 years ago by Nicklas Nordborg

Milestone: Reggie v4.23.3Reggie v4.24

The Reggie 4.23.3 milestone was never released separately. Changes was merged to Reggie 4.24.

Note: See TracTickets for help on using tickets.