Opened 5 years ago

Closed 5 years ago

#764 closed task (fixed)

Support for neoprep in the library preparation

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v3.4
Component: net.sf.basedb.reggie Keywords:
Cc:

Description (last modified by Nicklas Nordborg)

With the neoprep we will be able to go directly from RNA to libraries. We'll still have to register mRNA items to indicate what is going to be processed in a batch (typically 16 RNA).

We need to select barcodes in this step and specify a target molarity and fragment size for the final libraries.

Registration go directly to Libraries (skipping mRNA and cDNA). No Caliper or Qubit files will be available. The information entered in the first step should be used instead. Information about library size, molarity and volume is entered in the registration and other values (concentration and quantity) are calculated.

We might have to create a new set of wizards to handle the neoprep path since it might be tricky to modify the existing wizard so they work with both the manual protocol and the neoprep.

Most downstream wizards will probably need more or less changes to be able to find information that they need.

Change History (25)

comment:1 Changed 5 years ago by Nicklas Nordborg

Milestone: Reggie v3.xReggie v3.4
Status: newassigned

comment:2 Changed 5 years ago by Nicklas Nordborg

After getting more information about the NeoPrep we have settled for the following design idea:

  • RNA (or !RNANormalizedAliquot) is linked directly to a Library item (skipping both mRNA and cDNA items)
  • The Library items are placed on a NeoPrepPlate which is a 2x8 bioplate that represents the actual "Library card" used in the NeoPrep.
  • Barcodes are assigned to the Libraries
  • Library registration need to register concentration and size of the libraries. It is yet unclear if this can be done via output files from the NeoPrep or if we should just use the values that was aimed for (eg. 10nM/10µl)
  • Individual libraries are not saved after a pool has been created and successfully sequenced. The "Library card" may be saved for a few days and if something fails with the pooling or sequencing it would be possible to create a new pool with the same libraries.

comment:3 Changed 5 years ago by Nicklas Nordborg

(In [3284]) References #764: Support for neoprep in the library preparation

Installing 16-well (8x2) plate geometry and NeoPrep plate type to be used in the NeoPrep library preparation path.

comment:4 Changed 5 years ago by Nicklas Nordborg

(In [3286]) References #764: Support for neoprep in the library preparation

Re-organises the Library preparation section on the index page. There are now two entry points for designing a new library preparation. The first should be the same as the old "Create new mRNA plate" wizard and the second is a new "Create NeoPrep plate" wizard.

The path leading to libraries has been split into two sections, one for manual library preparation and has all the old wizards, and one path for NeoPrep with some new wizards.

The counter service has been updated to count NeoPrep plates at various stages.

Note that none of the wizards have been implemented yet.

comment:5 Changed 5 years ago by Nicklas Nordborg

(In [3288]) References #764: Support for neoprep in the library preparation

Started to adopt the "Select RNA" wizard to work with both 96-well plates and NeoPrep plates:

  • Titles and headers are modified
  • Plate name generation create !NeoPrepPlateNNNN plate names
  • Amount of RNA is set to 0.1µg and QC is disabled
  • Plate size is set to 8x2.

Pool layout selection does not work. We need a different set of pool layouts for NeoPrep.

comment:6 Changed 5 years ago by Nicklas Nordborg

(In [3289]) References #764: Support for neoprep in the library preparation

Added pool schemas and barcode layouts for the NeoProp. The '2 pools x 8 samples' will be used only temporarily for testing.

All pool schemas now have a type which can be either 'manual' or 'neoprep'. The 'Assign barodes' wizard has been updated to only use the 'manual' pools.

comment:7 Changed 5 years ago by Nicklas Nordborg

(In [3290]) References #764: Support for neoprep in the library preparation

Handle selection of barcode variants. The barcode is currently displayed in the regular well and the actual barcode information is not yet loaded from the server.

comment:8 Changed 5 years ago by Nicklas Nordborg

(In [3297]) References #764: Support for neoprep in the library preparation

Display barcode selection for NeoPrep outside the main table. This might break other plate-like protocols and pages so they should be checked as well.

comment:9 Changed 5 years ago by Nicklas Nordborg

(In [3299]) References #764: Support for neoprep in the library preparation

Fixes some display issues with other plate-layout lab protocols.

comment:10 Changed 5 years ago by Nicklas Nordborg

(In [3300]) References #764: Support for neoprep in the library preparation

Added support for modifying selected barcodes.

comment:11 Changed 5 years ago by Nicklas Nordborg

(In [3301]) References #764: Support for neoprep in the library preparation

Modified dilution calculations so that 45µl is used for NeoPrep and if less than 1µl RNA is required a larger mix is used.

comment:12 Changed 5 years ago by Nicklas Nordborg

(In [3302]) References #764: Support for neoprep in the library preparation

Submitting and registering NeoPrep plates. The registration is done by the MRnaServlet so that we don't have to duplicate code in the LibPrepServlet.

The 'Large mix' items make the lab protocols go bananas since they assume that everything is mixed to the same volume/concentration and everything more than the normal amount is QC-flagged. The mixing calculations can only be reproduced correctly if we also store the target amount and volume of RNA and the QC-flag needs to be a separate annotation.

comment:13 Changed 5 years ago by Nicklas Nordborg

(In [3303]) References #764: Support for neoprep in the library preparation

Adding UseForQC and DilutionConc annotations to be used on mRNA and Library items so that dilution protocol can be calculated properly.

This change is incomatible with older Reggie version so before updating it is important that there are no mRNA plates waiting for dilution since there is a risk that the protocol will be incorrect after updating.

comment:14 Changed 5 years ago by Nicklas Nordborg

(In [3308]) References #764: Support for neoprep in the library preparation

Started with the NeoPrep lab protocols for library preparation. The placement, dilution volumes and barcode information should be in place, but the protocol still include dates, etc. that is more related to the manual library preparation.

(Manually added since post-commit-hook fails after upgrade)

Last edited 5 years ago by Nicklas Nordborg (previous) (diff)

comment:15 Changed 5 years ago by Nicklas Nordborg

(In [3309]) References #764: Support for neoprep in the library preparation

Started with the NeoPrep registration wizard. This is currently based on the regular library registration with all file fields removed. Values for molarity, volume, and size are hard-coded in the servlet code. This obvoiusly needs to change in the future.

The pool servlet has been updated to also accept NeoPrep plates, but the display is not optimized yet for anything not 8x12 plates.

Other changes are related to the Library.getRna() method which should be used when needing to move up from Library to RNA level without having to mess with if the path goes along cDNA/mRNA items or not.

comment:16 Changed 5 years ago by Nicklas Nordborg

(In [3310]) References #764: Support for neoprep in the library preparation

Pooling wizard and pooling protocols should now work with NeoPrep plates. Migth still need some more testing and optimizations.

comment:17 Changed 5 years ago by Nicklas Nordborg

(In [3315]) References #764: Support for neoprep in the library preparation

Adding NeoPrep Library card coordinates (A-P, 1-16) to the plate view.

comment:18 Changed 5 years ago by Nicklas Nordborg

(In [3316]) References #764: Support for neoprep in the library preparation

The auto-select RNA function must filter out RNA having either child mRNA or Library items, or the same RNA will be selected every time when creating a NeoPrep plate (since they never get any mRNA).

The auto-select RNA function now selects the pre-normalization protocol that best matches the required RNA quantity. Eg. NeoPrep protocol when doing a NeoPrep plate and Manual TruSeq otherwise.

comment:19 Changed 5 years ago by Nicklas Nordborg

(In [3317]) References #764: Support for neoprep in the library preparation

Counters must also take into account the RNA items now can have a Library child instead of a mRNA.

comment:20 Changed 5 years ago by Nicklas Nordborg

(In [3319]) References #764: Support for neoprep in the library preparation

Updated NeoPrep lab protocols and registration to include values for library volume, molarity and size.

comment:21 Changed 5 years ago by Nicklas Nordborg

(In [3320]) References #764: Support for neoprep in the library preparation

Updated code that use CA_Size or QubitConc so that they fallback to LIBRARY_SIZE_EST and LIBRARY_CONC_EST if the Caliper/Qubit? measurements doesn't exists.

Most changes in the case summary, but also in the demux and alignment wizards.

comment:22 Changed 5 years ago by Nicklas Nordborg

(In [3321]) References #764: Support for neoprep in the library preparation

Updated code that use CleanupDate so that it fallback to NeoPrepDate.

comment:23 Changed 5 years ago by Nicklas Nordborg

Description: modified (diff)

comment:24 Changed 5 years ago by Nicklas Nordborg

(In [3330]) References #764: Support for neoprep in the library preparation

Adjust column width to make the second step align with the first.

comment:25 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.