Opened 6 years ago

Closed 6 years ago

#508 closed defect (fixed)

Library plates remain in the 'Create pooled libraries' wizard after pools have been created

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.13
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

For some reason the Create pooled libraries wizard on production server currently display LibPlate0022 and LibPlate0023 in the list even though pools have already been created from both plates. For plate 22 the pools have also been registered. For plate 23 the pooling starts next week.

A library plate should not be in the list once pools have been created from the plate.

A preliminary investigation indicates that this may be related to some libs with 0 quantity. The pooling wizard handles this by not including the libs in the pool, but it is not certain if the parent RNA is flagged for re-processing or not. The pooling wizard searches for non-flagged, non-pooled libs when building the lib plate list, which may cause that plate 22 and 23 remains in the list.

Change History (4)

comment:1 Changed 6 years ago by Nicklas Nordborg

After some initial investigations it seems like the root cause is that some libs have a 0ng/µl measured concentration from the Qubit. The Library registration wizard import the Qubit and Caliper files without problems, but the calculations for Molarity and Original quantity of course results in 0 for both.

In the next step, the Create pooled libraries wizard simply ignore all libraries with 0 remaining quantity. Those libraries remain in not-yet-pooled state which is causing the library plates to remain selectable in the wizard even though the majority of the libraries have been pooled. This issue can be fixed relatively simple by improving the filter that is searching for unpooled libraries.

Another and more serious issue is that the failed libraries have ended up in a dead end. They will not be selectable for pooling and there is no information on the parent RNA items that re-processing is needed. This must be handled either by the Library registration or the Create pooled libraries.

comment:2 Changed 6 years ago by Nicklas Nordborg

Status: newassigned

comment:3 Changed 6 years ago by Nicklas Nordborg

(In [2032]) References #508: Library plates remain in the 'Create pooled libraries' wizard after pools have been created

The problem with 0-quantity libraries is now handled by the Create pooled libraries wizard. It no longer excludes those libraries, but display them in the plate layout. Libraries that have a molarity below 25% of the target molarity are then automatically marked with flag ExcludeFromPool. The exclusion can be manully overridden to include some libraries in the pool, but note that just a few with too low molarity may result in negative mixing volume for EB.

The regular registration is then used to flag the libraries and parent RNA for re-processing.

NOTE! A manual fix is needed to flag library items and their parent RNA for plates that have already been processed with the buggy code.

comment:4 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

Added instructions for manually fixing issues with library and RNA items. See Reggie 2.13 update notes .

Note: See TracTickets for help on using tickets.