Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#1434 closed enhancement (fixed)

Improve the release exporter step that searches for existing files

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.42
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The problem is that it takes a very long time now and there is a risk that there is a timeout before the result is complete. It typically helps to re-start the job, but it will fail again on a later release. It may require several restarts before it works.

It would also be nice to get information about the search in the progress reporter. Currently the search doesn't happen until the first file is going to be created so it seems like the export of the first item takes a very long time.

There are some other things that could be improved as well:

  • We should only search x.0 releases since those are the only ones that get new files. It should save us a lot of time.
  • Sorting of the releases is done with sort which is an alphabetical sort. This may cause problems later when we reach release number "10.0" since it would be sorted before all other single-digit releases. This can be fixed by sort -n which does a numerical sort.

Change History (2)

comment:1 by Nicklas Nordborg, 14 months ago

Resolution: fixed
Status: newclosed

In 6962:

Fixes #1434: Improve the release exporter step that searches for existing files

comment:2 by Nicklas Nordborg, 14 months ago

In 6963:

References #1434: Improve the release exporter step that searches for existing files

We also need to check the '2.2' directory since it is the first release with the release exporter and contains a lot of files.

Note: See TracTickets for help on using tickets.