Opened 3 years ago

Closed 3 years ago

#1141 closed enhancement (fixed)

Improve error message when an item is registred in duplicate

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.23
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

This happens very rarely. The typical use case is that two users is registering something new at the same time. For example, one user is registering a consent and another is registering a referral form. This could lead to an error message:

Case 'xxxx' has already been registered by <the other user>.

It would be nice to have some time information here if possible since it would be easier to realize that the error is a result from simultaneous registration and not a bug, permission issue or something else. For example:

Case 'xxxx' has already been registered by <the other user> 1 minute ago.

Change History (1)

comment:1 Changed 3 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 5423:

Fixes #1141: Improve error message when an item is registred in duplicate

The ensureNonExistingItem() method now uses the change history log to get the creation date and time which is added to the error message.

Also found the the consent form registration was missing a check for duplicate items.

Note: See TracTickets for help on using tickets.