Opened 6 years ago

Closed 6 years ago

#739 closed defect (fixed)

Gene report doesn't pick up default path to template.pdf

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: Reggie v3.2
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

In reggie-config.xml there is a setting for specifying the path to the template pdf used by the Gene report plug-in. The default value is empty which according to the documentation should mean: 'template.pdf' in the same directory as the R script.

Though it seems like it doesn't work since we get a null value for the path:

...
Caused by: java.lang.NullPointerException
  at java.io.File.<init>(File.java:277)
  at net.sf.basedb.reggie.r.RScriptDefinition.checkFile(RScriptDefinition.java:54)
  at net.sf.basedb.reggie.r.GeneReport.<init>(GeneReport.java:108)
  at net.sf.basedb.reggie.plugins.GeneReportPlugin.run(GeneReportPlugin.java:145)
...

Change History (1)

comment:1 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3142]) Fixes #739: Gene report doesn't pick up default path to template.pdf

Incorrect parameter order when getting the config value for "rscript/gene-report/template" caused the default value to always be null.

Note: See TracTickets for help on using tickets.