Opened 6 years ago

Closed 6 years ago

#734 closed defect (fixed)

The create new mRNA plate wizard should reset RNA marked for re-processing

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v3.1
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The auto-selection functionality contains an option for selecting RNA items marked with AutoProcessing=ReProcess. This option is enabled by default and works as intended, but the ReProcess flag is not reset when the mRNA is registered which means that the auto-select wizard will continue to select this RNA item until the flag is manually cleared.

Change History (1)

comment:1 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3112]) Fixes #734: The create new mRNA plate wizard should reset RNA marked for re-processing

The AutoProcessing and Flag annotations are cleared and the RNA is removed from the Flagged RNA biomaterial list. Also display a message in the gui when a RNA marked for ReProcess? has been selected (manually or auto). Fixes a spelling mistake on Qiacube date annotation causing gui to display a "No Qiacube date" warning for all manually selected RNA.

Note: See TracTickets for help on using tickets.