Opened 6 years ago

Closed 6 years ago

#667 closed defect (fixed)

Library registration wizard complains about missing concentration for Stratagene

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.16.3
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The qubit and caliper files seems to be ok, but the library registration wizard output several error messages (one for each Stratagene sample which doesn't have a concentration measurement):

File 'LibPlate.....csv' line 86: 
   Missing concentration for extract 'Stratagene.r013.m13.c.lib'

The workaround is to remove all lines without a concentration from the file.

Change History (4)

comment:1 Changed 6 years ago by Nicklas Nordborg

First thing I noticed is that the 'generate fake file' feature that is used for testing this wizard is not generating files that are matching the real files. Eg. the test files have concentration values for all libraries including Stratagene and they are also included in the caliper well table file. To be compatible with the real world the qubit file should not include any concentration values for the last row on the plate and those libraries should not be included in the well table file at all.

comment:2 Changed 6 years ago by Nicklas Nordborg

(In [2820]) References #667: Library registration wizard complains about missing concentration for Stratagene

Updated the test file generation so that they look like what is found in the lab. It is not possible to reproduce the problem.

comment:3 Changed 6 years ago by Nicklas Nordborg

Seems like this was caused by changes in [2675] when trying to improve the error handling in the Caliper importer. Previously errors were always reported as if they were in the caliper well table file. Since the line numbers doesn't have to match between the files (qubit file is sorted by column and caliper file by row) this could be a bit confusing.

comment:4 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [2821]) Fixes #667: Library registration wizard complains about missing concentration for Stratagene

The pre-parsing of the qubit file now allows missing concentration values and only pre-generate error messages in case the concentration values are requested by the caliper importer.

The caliper plate importer now handle external lookup errors separately so that it is possible to know if the error is in the caliper file or in the qubit file.

Note: See TracTickets for help on using tickets.