Opened 6 years ago

Closed 5 years ago

#630 closed task (fixed)

Start cufflinks

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.17
Component: net.sf.basedb.reggie Keywords:
Cc:

Description (last modified by Nicklas Nordborg)

The wizard is started after successfully aligning data. In the first step AlignedSequences items should be selected. The default list should contain items with annotation AnalysisResult=Successful and AutoProcessing!=Disable and not having any child items.

For each selected item, the wizard create one raw bioassay child item names as <lib-name>.g.k.a.t

More information will follow...

Change History (14)

comment:1 Changed 6 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 5 years ago by Nicklas Nordborg

Milestone: Reggie v2.xReggie v2.17
Priority: majorcritical
Status: newassigned

comment:3 Changed 5 years ago by Nicklas Nordborg

(In [2721]) References #630: Start cufflinks

It is possible to start and run cufflinks. Results files seems to be generated ok and are linked with the raw bioassay item in BASE. No connection yet to array design and no import of data.

comment:4 Changed 5 years ago by Nicklas Nordborg

(In [2722]) References #630: Start cufflinks

Added possibility to select an array design.

comment:5 Changed 5 years ago by Nicklas Nordborg

(In [2726]) References #630: Start Cufflinks

Switches to hg38 in the default configuration.

comment:6 Changed 5 years ago by Nicklas Nordborg

(In [2739]) References #630. Check that values from the database such as paths and names of items are safe to use in scripts. The check is currently very strict and only allow letters, digits, dot, underscore and hyphen.

comment:7 Changed 5 years ago by Nicklas Nordborg

(In [2750]) References #630: Start cufflinks

Added support for re-mapping some tracking_id values to other values. This step is optional and only performed if a mapping file has been specified in <cufflinks>/<tracking-id-map> setting.

The current mapping file is base on the UCSC_Human_hg19_knownGenes_GTF_appended_10sep2012.gft file and doesn't work if running Cufflinks with UCSC_hg38_knownGenes_22sep2014.gtf.

The problem is that the mapping file will replace some tracking_id values with values that are not found in the GTF and the subsequent import to BASE will fail with:

Item not found: Feature[Feature ID=uc021vwt.1] 
doesn't exist on array design 
on line 13967 in file 'isoforms.fpkm_tracking'

comment:8 Changed 5 years ago by Nicklas Nordborg

(In [2806]) References #630: Start cufflinks

New tracking-id mapping file that is matching the hg38 GTF file. The mapping file will be stored at the same location as the GTF file.

comment:9 Changed 5 years ago by Nicklas Nordborg

(In [2807]) References #630: Start cufflinks

Added option to select an import configuration in the start cufflinks wizard. If no importer is selected then only cufflinks will be run. Raw data is not automatically imported.

comment:10 Changed 5 years ago by Nicklas Nordborg

(In [2809]) References #630: Start cufflinks

Must wait for the fix commands to complete or the following mv may overwrite the original file before it has been completely processed.

comment:11 Changed 5 years ago by Nicklas Nordborg

(In [2847]) References #630: Start cufflinks

Re-organized configuration parameter and grouped array design and plug-in configuration together.

comment:12 Changed 5 years ago by Nicklas Nordborg

(In [2850]) References #630 (and #675): Start cufflinks

Adding support for just looking at a subset (chr1) of aligned sequences when running in debug mode.

Make sure '/debug' is present in data folder when running in debug mode.

comment:13 Changed 5 years ago by Nicklas Nordborg

(In [2884]) References #630: Start cufflinks

Changed options for Cufflinks.

comment:14 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.