Opened 8 years ago

Closed 8 years ago

#375 closed defect (fixed)

Personal registration wizard should set creation date on specimen tubes

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v2.4
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The specimen tube registration wizard set the 'sampling date' as both an annotation (SamplingDateTime) and as the 'created date' on the specimen item. This is as it should be.

The problem is that the personal registration wizard has the possibility to add/modify this date, but the update is only happening for the annotation, not the 'created date'. This can easily be seen as some specimen items have an annotation value but no 'created date' value. It is also possible that some specimen item may have different values.

We need to update reggie so that the personal registration wizard also update the 'created date' and then manually fix existing specimen items to make sure that both values are the same (ignoring the time part from the annotation)

Change History (1)

comment:1 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [1595]) Fixes #375: Personal registration wizard should set creation date on specimen tubes

Note: See TracTickets for help on using tickets.