Opened 4 weeks ago

Closed 4 weeks ago

#1004 closed enhancement (fixed)

Auto-confirmation after demux should start Tophat/Hisat jobs independently of each other

Reported by: nicklas Owned by: nicklas
Priority: minor Milestone: Reggie v4.13
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The DemuxAutoConfirmer code that starts Tophat and Hisat alignment jobs is a single piece of code. If there is a problem no jobs will created. This should be changed so that if the problem is in the Hisat-specific part only the Hisat jobs should be affected, and vice versa.

Change History (2)

comment:1 Changed 4 weeks ago by nicklas

  • Status changed from new to assigned

comment:2 Changed 4 weeks ago by nicklas

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4623]) Fixes #1004: Auto-confirmation after demux should start Tophat/Hisat? jobs independently of each other

The code in DemuxAutoConfirmer has been updated to use two separate transactions for starting Tophat and Hisat jobs. Unless there is some common error (eg. cluster is down) failure to register jobs for one pipeline should not affect the other pipeline.

Note: See TracTickets for help on using tickets.