Changes between Initial Version and Version 1 of Ticket #801, comment 57


Ignore:
Timestamp:
Oct 20, 2015, 1:01:39 PM (6 years ago)
Author:
olle
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #801, comment 57

    initial v1  
    11Design update:
    22
    3  * When javascripts sends a request to `LibPrepServlet` for downloading a reagent lot number file, parameter "`consumablesFileName`" should change name to "`referenceName`", since the name is only used in the name of the file to download, and in the future one might want to call this functionality in cases where the reference name is not a file name, but e.g. a kit name.
     3 * Wizards "Add new consumables lot number file" and "Inspect library preparation kit data" in sub-section "Reagent kit management wizards" should be updated when javascripts send a request to `LibPrepServlet` for downloading a reagent lot number file by exchanging name of parameter "`consumablesFileName`" for "`referenceName`", since the name is only used in the name of the file to download, and in the future one might want to call this functionality in cases where the reference name is not a file name, but e.g. a kit name.
    44
    55 1. Javascript file `add_consumables_lot_number_file.js` in `resources/libprep/` updated:[[BR]]a. Functions `downloadReagentLotNoFile()` and `downloadReagentLotNoFileResults(response)` updated by exchange of parameter name "`consumablesFileName`" for "`referenceName`", when calling `LibPrepServlet`.[[BR]]b. Function `submit()` updated by exchange of JSONObject key "`consumablesFileName`" for "`referenceName`", when calling `LibPrepServlet`.