Opened 4 years ago

Closed 4 years ago

#925 closed defect (fixed)

Item not found: Group[....] in "Mark extracts for retraction" wizard

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: Reggie v4.9
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The "Mark extracts for retraction" wizards fails with a "Item not found: Group[....]" message after entering a case number and clicking next.

It was a bit tricky to reproduce this since it depends on the permissions on the logged in user and if someone else with more permissions has been logged in and used certain wizards before or not.

The simplest way to reproduce is to restart the server and log in as a user with only PatientCurator and SCAN-B Lab permission. This should always cause the problem in the retraction wizard. The problem goes away if a user with Administrator logs in an uses the same wizard. It may also go away after at least one YellowLabel specimen has been registered for the site in question.

The root cause seems to be the connection between Sites and Group items implemented as part of #891 [4002]. This causes some information to not load until a user with permission to access the group information was logged in. The information is then cached and can be used by any user.

The proper solution is to force Reggie to load the information when starting up as part of one of the services....

However, in this particular case in the retraction wizard we don't need the group information so it is probably easier to just fix this for now and then implement the proper fix if a similar issue pops up in the future....

Change History (1)

comment:1 Changed 4 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [4260]) Fixes #925: Item not found: Group[....] in "Mark extracts for retraction" wizard

A bit confusing with two asJSONObject() methods... We should use the one without a DbControl parameter to avoid hitting the database.

Note: See TracTickets for help on using tickets.