Opened 5 years ago

Closed 5 years ago

#838 closed enhancement (fixed)

Partial confirmation of demux job

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.1
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The auto-confirm functionality for demux jobs have some rules that are for the entire demux and some rules that are for individual libraries (see #717).

The rule about no DemuxWarnings should still stop the entire sequencing run.

The rules about number of reads and fragment size should only stop the libraries that not fulfill them.

The simple solution is to simply not start the alignment stop for those libraries. The drawback is that it will not be possible to see the information from the "Confirm demux" wizard since the libraries will be waiting in the "Start alignment" wizard.

It would be better to add support for some kind of "partial confirmation". The sequencing run should still be visible in the "Confirm demux" and it should display the same information as before, except that libraries that passed the partial confirmation should not have the options to flag or start alignment.

Change History (4)

comment:1 Changed 5 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 5 years ago by Nicklas Nordborg

(In [3723]) References #838: Partial confirmation of demux job

Added Partial to enumeration for the AnalysisResult annotation. It should be set on DemuxedSequences by the auto-confirm wizard (not yet implemented). Jobs that are linked to items with this annotation will show up in the "Confirm demux" wizard.

The second step in the "Confirm demux" wizard show all child MergedSequences (as before) but those that have already been auto-confirmed doesn't have checkboxes for "Flag RNA" or "Align".

The "Failed" option is also disabled since it not clear what should happen to the auto-confirmed libraries if this is selected.

comment:3 Changed 5 years ago by Nicklas Nordborg

(In [3724]) References #838: Partial confirmation of demux job

The auto-confirmation wizard for the demux step has been updated to start alignment for libraries that pass the rules. If there are some libraries that doesn't pass "AnalysisResult?" will be set to "Partial" and the demux will show up for manual confirmation.

comment:4 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.