Opened 5 years ago

Closed 5 years ago

#806 closed enhancement (fixed)

Confirmation wizards fail to report problems with deleting items as errors

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v3.6
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

This is caused by a BASE bug: http://base.thep.lu.se/ticket/1953#ticket

But the wizard is not well prepared to handle an error in this stage. The error message is displayed in the list of messages but it has the green 'ok' icon and it is easy to miss that since the list of messages can be long.

The error handling should be improved so that at least the error message easier to detect (eg. use the 'error' icon).

The other confirmation wizards that also delete items after a failure may have the same problem so they should also be checked.

Change History (2)

comment:1 Changed 5 years ago by Nicklas Nordborg

Summary: Confirm demux wizard may fail to delete itemsConfirmation wizards fail to report problems with deleting items as errors

comment:2 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3482]) Fixes #806: Confirmation wizards fail to report problems with deleting items as errors

The message need to be prefixed with '[Error]'.

Note: See TracTickets for help on using tickets.