Opened 6 years ago

Closed 6 years ago

#757 closed defect (fixed)

Some latest RNAQC items are not fetched in the Flagged RNA wizard

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v3.2.1
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The common pattern seems to be that the missing RNAQC items are not located on a bioplate, and thus there is no QCRunDate annotation. In this case, the 'creation date' should be used instead, but it seems like it is not working.

Change History (2)

comment:1 Changed 6 years ago by Nicklas Nordborg

(In [3186]) References #757: Some latest RNAQC items are not fetched in the Flagged RNA wizard

This should fix the problem with RNAQC items not located on a bioplate. The root cause was an INNER JOIN added in [3166]. Changing the to a LEFT JOIN should work.

I'll keep this open since I want to get rid of the duplicate implementation in Case summary.

comment:2 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3188]) Fixes #757: Some latest RNAQC items are not fetched in the Flagged RNA wizard

Refactored the RNAQC loading so that the search for the last RNAQC item is made in a single place. The Case summary, Flagged RNA wizard and Create mRNA wizard should now be consistent.

Note: See TracTickets for help on using tickets.