Opened 6 years ago

Closed 6 years ago

#753 closed defect (fixed)

Case summary breaks if no stained histology has GoodStain

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v3.2.1
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

Left column display ok down to Histology section. The "Score" section is incomplete and the right column is a mess with some more or less hidden error message.

Fortunately, the error message is also displayed in the devloper web console.

TypeError: bestStain is undefined
CaseSummary</cs.caseInfoLoaded@https://casa4.bmc.lu.se/lorry/extensions/reggie.jar/reports/case-summary.js?v=3.2:207:5
Wizard</internal.asyncCallbackWrapper@https://casa4.bmc.lu.se/lorry/extensions/reggie.jar/reggie-2.js?v=3.2:905:6

Change History (3)

comment:1 Changed 6 years ago by Nicklas Nordborg

Milestone: Reggie v3.xReggie v3.2.1
Status: newassigned

comment:2 Changed 6 years ago by Nicklas Nordborg

(In [3178]) References #753: Case summary breaks if no stained histology has GoodStain?

This should fix the current problem which was caused by trying to display the HE glass position of the stained sample with the GoodStain annotation.

comment:3 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.