Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#727 closed defect (fixed)

RNAQC importer says "No 'RNA Quality Score' value found....; using -100 instead" for all wells

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.18.2
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The 'Import RQS scores from Caliper well table file' wizard seems to have stopped working. The Caliper well table files we have tried with seems to be ok, and we also get the same problem with well table files that has already been imported (for example CaliperPlate0035_2014-11-17_1_WellTable.csv).

The problem is that as soon as the well table file is selected it will display a lot of warning (for all wells):

CaliperPlate0035_2014-11-17_1_WellTable.csv: 
No 'RNA Quality Score' value found for '2210834.1.l.r.qc' (A1); using -100 instead

Attachments (1)

no_rqs.png (95.5 KB) - added by Nicklas Nordborg 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Nicklas Nordborg

Attachment: no_rqs.png added

comment:1 Changed 6 years ago by Nicklas Nordborg

I think I found the cause of this. The background is that #669 introduced a check that all biomaterial on the caliper plate also had RQS values in the well table file. This was implemented by first setting the status for all extracts to 'missing', and then as each extract was found in the file, remove them from the missing status. As it turned out a critical code line (missingExtracts.remove()) was contained in a debug output line (CaliperPlateImporter line 312).

This debug line was initially left in the code that was released in Reggie 2.17, but was later removed as part of #699 and released in Reggie 2.17.2.

The solution would be to add the call to missingExtracts.remove() again and this time not as a debug line.

comment:2 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [3061]) Fixes #727: RNAQC importer says "No 'RNA Quality Score' value found....; using -100 instead" for all wells

comment:3 Changed 6 years ago by Nicklas Nordborg

(In [3062]) References #727: RNAQC importer says "No 'RNA Quality Score' value found....; using -100 instead" for all wells

[3061] was made in the 2.17-stable branch which is no longer used. This is the same fix in the 2.18-stable branch.

Note: See TracTickets for help on using tickets.