Opened 6 years ago

Closed 6 years ago

#674 closed task (fixed)

Generate document with report of sequencing results

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.18
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

When the secondary analysis pipeline has been completed we should have enough information to be able to generate a report with our findings.

The exact details of what should be in the report have to be specified. The report should be attached to an item (which one?) and is an indication that the processing has been completed for that sample.

If possible it would be nice if the document is a PDF, but it would be good enough with a self-contained HTML file as well. Self-contained = it doesn't depend on any external resources, eg. scripts, style sheets, images, etc.

Change History (23)

comment:1 Changed 6 years ago by Nicklas Nordborg

(In [2863]) References #674: Generate document with report of sequencing results

Added utility classes for running R scripts in general and the 'geneReport' script in particular.

Added <rscript> section to the configuration file for holding settings related to R and R scripts.

comment:2 Changed 6 years ago by Nicklas Nordborg

(In [2870]) References #674: Generate document with report of sequencing results

Added iText JAR file to project.

comment:3 Changed 6 years ago by Nicklas Nordborg

(In [2871]) References #674: Generate document with report of sequencing results

First version of a plug-in that generate a PDF report. It can currently only be run from the single-view page for a raw bioassay with "cufflinks" raw data type.

comment:4 Changed 6 years ago by Nicklas Nordborg

(In [2876]) References #674: Generate document with report of sequencing results

Added support for the gene report plug-in to be executed from the list context.

comment:5 Changed 6 years ago by Nicklas Nordborg

(In [2877]) References #674: Generate document with report of sequencing results

Added new entry on the index page for "Gene report" wizard.

Implemented a counter that can count number of confirmed raw bioassays that has no PDF already.

comment:6 Changed 6 years ago by Nicklas Nordborg

(In [2878]) References #674: Generate document with report of sequencing results

Changed 'Confirm' to 'Gene report' in cufflinks confirmation wizard.

comment:7 Changed 6 years ago by Nicklas Nordborg

(In [2879]) References #674: Generate document with report of sequencing results

First versin of the "Gene report" wizard. It schedules selected raw bioassays as a job for the GeneReportPlugin.

comment:8 Changed 6 years ago by Nicklas Nordborg

(In [2883]) References #674: Generate document with report of sequencing results

Added support for specifying name of the generated PDF either as a job parameter or in the configuration file.

comment:9 Changed 6 years ago by Nicklas Nordborg

Status: newassigned

comment:10 Changed 6 years ago by Nicklas Nordborg

(In [2891]) References #674: Generate document with report of sequencing results

Updating parameter descriptions.

comment:11 Changed 6 years ago by Nicklas Nordborg

(In [2894]) References #674: Generate document with report of sequencing results

Added support for including a site-specific logotype in the upper right corner in the PDF. The logotypes are note distributed with Reggie due to legal issues, but have to be configured in reggie-config.xml (in logos/*) section.

comment:12 Changed 6 years ago by Nicklas Nordborg

(In [2911]) References #674: Generate document with report of sequencing results

Added a "gene reports combiner" plug-in. This plug-in takes existing gene report pdf:s and

  • add patient information (if the logged in user has permissions to read it)
  • combine the pdf's into a single pdf (one reporter per page)

The resulting PDF can only be downloaded to the user's computer and not saved in BASE since it may lead to leaking personal information.

After using this plug-in it is up to the user to protect sensitive information.

comment:13 Changed 6 years ago by Nicklas Nordborg

(In [2961]) References #674: Generate document with report of sequencing results

Bug in permission check for personal information parameter. There was no connection to the database so the check for other users than root could not be completed.

comment:14 Changed 6 years ago by Nicklas Nordborg

(In [2973]) References #674: Generate document with report of sequencing results.

Same fix for libraries without a library plate as for the start alignment and start cufflinks wizards (#697).

comment:15 Changed 6 years ago by Nicklas Nordborg

(In [2988]) References #674: Generate document with report of sequencing results

Added utility function for writing gridlines around the pdf.

comment:16 Changed 6 years ago by Nicklas Nordborg

(In [2990]) References #674: Generate document with report of sequencing results

Using a template that is filled in with generated plot data and some other information.

comment:17 Changed 6 years ago by Nicklas Nordborg

(In [2991]) References #674: Generate document with report of sequencing results

Adding possibility to call more than one R function on each execution. Use the 3.1 gene report script with two reference cohorts.

comment:18 Changed 6 years ago by Nicklas Nordborg

(In [2993]) References #674: Generate document with report of sequencing results

Improved error handling if some files are missing.

comment:19 Changed 6 years ago by Nicklas Nordborg

(In [2997]) References #674: Generate document with report of sequencing results

Fixes issues with character encoding (åäö is not available in default Helvetica font) by explicitely using OpenSans? font (downloaded from http://www.fontsquirrel.com/fonts/open-sans).

comment:20 Changed 6 years ago by Nicklas Nordborg

(In [2998]) References #674: Generate document with report of sequencing results

Cleaned up gene reporters combiner plug-in so that it only collect multiple pdf:s into a single document. No personal information is added.

comment:21 Changed 6 years ago by Nicklas Nordborg

(In [2999]) References #674: Generate document with report of sequencing results

Clarifying some configuration options.

comment:22 Changed 6 years ago by Nicklas Nordborg

(In [3002]) References #674: Generate document with report of sequencing results

Include script version in "Creator" field of the generated pdf file.

Set default values in one place for both calls to geneReport().

comment:23 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.