Opened 6 years ago

Closed 6 years ago

#662 closed defect (fixed)

Race conditions in demux script

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: critical Milestone: Reggie v2.16.2
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The demux script starts some of the steps in the background, but there is no 'wait' statement to make sure that they have completed before moving on to steps that require that the background script has been completed.

Change History (1)

comment:1 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [2810]) Fixes #662: Race conditions in demux script

This was caused by changes in [2730] that remove files early in order to lower the used disk space.

Fixed by not starting any commands in the background.

Note: See TracTickets for help on using tickets.