Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#548 closed task (fixed)

Register Demux and Merge as ended

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v2.16
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

Part of #533.

This wizard is used to register that demuxing and merging has been completed. The wizard should show DemuxedSequences items that is missing 'creationDate'.

In this wizard we should register the following information:

  • Date: CreationDate column
  • Software and protocol used for demux (if not specified in the previous step)
  • Software and protocol used for merge (if not specified in the previous step)
  • If the demux step was successful or not.
  • Comments: Description column

If the demux was not successful decide if:

  • Re-run the demux with different parameters
  • Flag the PooledLibrary items for re-sequencing

If the demux was successful:

  • Register files that was generated: <sample>.R1.fastq, <sample>.R2.fastq (Use annotation??)
  • Number of reads for each lib. How is this information collected? File upload/manual entry?
  • If number of reads too low, flag Library for re-sequencing.
  • More??

Change History (21)

comment:1 Changed 6 years ago by Nicklas Nordborg

Milestone: Reggie v2.15Reggie v2.16

comment:2 Changed 6 years ago by Nicklas Nordborg

Status: newassigned

comment:3 Changed 6 years ago by Nicklas Nordborg

(In [2364]) References #548: Register Demux and Merge as ended

Started with the wizard. The first step allows the user to select among finished but not confirmed jobs. The second step list all libraries from the flow cells. There is an option to mark the entire demuxing step as failed and flag the pools for re-sequencing. Preparations for flagging individual libraries have also been done, but there is currently no information that can help the user make a descision.

The second step is not yet functional and it is not possible to finalize the registration.

comment:4 Changed 6 years ago by Nicklas Nordborg

(In [2366]) References #548: Register Demux and Merge as ended

Display number of reads and passed filter information when registering the demux/merge step.

comment:5 Changed 6 years ago by Nicklas Nordborg

(In [2367]) References #548: Register Demux and Merge as ended

Submit registration and store demux/merge results. The step can be failed as a whole, or it is possible to flag indivudual RNA items for reprocessing and continue with alignment for others.

comment:6 Changed 6 years ago by Nicklas Nordborg

(In [2420]) References #533, #547, #548, #593, #595. Renamed FilteredSequences subtype to MaskedSequences and the related software and protocol type. Renamed annotations NumReads to READS and PassedFilterReads to PF_READS and added new annotation for number of reads on the masked (PM_READS) and aligned level (ALIGNED_PAIRS).

Lots of related changes in the code to make class and variable names match the new names.

comment:7 Changed 6 years ago by Nicklas Nordborg

(In [2437]) References #548: Register Demux and Merge as ended

Display demux statistics and warnings for flow cells.

comment:8 Changed 6 years ago by Nicklas Nordborg

(In [2438]) References #548: Register Demux and Merge as ended

Remove job folder input field since it doens't do anything.

comment:9 Changed 6 years ago by Nicklas Nordborg

(In [2458]) References #548: Register Demux and Merge as ended

Display failed demux jobs in the confirmation wizard.

Do not check 'align' for libraries that have 0 PF_READS.

comment:10 Changed 6 years ago by Nicklas Nordborg

(In [2459]) References #548: Register Demux and Merge as ended

Exit script if the data for a flow cell can't be found.

comment:11 Changed 6 years ago by Nicklas Nordborg

(In [2498]) References #548: Register Demux and Merge as ended

Display PT_READS in the confirmation wizard.

comment:12 Changed 6 years ago by Nicklas Nordborg

(In [2561]) References #548: Register Demux and Merge as ended

checkMd5 parameter should be false.

comment:13 Changed 6 years ago by Nicklas Nordborg

(In [2570]) References #548: Register Demux and Merge as ended

Register FASTQ file items pointing to the project archive (via sftp protocol). The FASTQ files are linked with their corresponding bioassays.

comment:14 Changed 6 years ago by Nicklas Nordborg

(In [2577]) References #548: Register Demux and Merge as ended

To avoid too many top-level folders, use two additional levels of subfolders based on the first two and four characers in the SCANB id. For example: /33/3306/3306492.1 instead of /3306492.1

comment:15 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

comment:16 Changed 6 years ago by Nicklas Nordborg

(In [2636]) References #571 and #547 and #548. The confirm demux wizard has been updated to the new script and style pattern.

Also added an option to delete items after a failed job and fixed the script so that it makes sure that the job, work and archive folders are empty before trying to use them.

comment:17 Changed 6 years ago by Nicklas Nordborg

(In [2640]) References #548: Register Demux and Merge as ended

Added an option to flag sequencing runs for re-demuxing after a failure.

comment:18 Changed 6 years ago by Nicklas Nordborg

(In [2681]) References #548: Register Demux and Merge as ended

Selecting 'failure' for an otherwise successful run would delete created items without asking about this. The 'delete items' and 're-try demux' options are now always visible and selectable if the 'failed' option is selected. They are selected by default only if the job failed.

comment:19 Changed 6 years ago by Nicklas Nordborg

(In [2682]) References #548: Register Demux and Merge as ended

Display calculated average fragment size and standard deviation. A warning is shown if the difference from the Caliper size (corrected for adapter size = CA_Size-2*59) is larger than the standard deviation.

comment:20 Changed 6 years ago by Nicklas Nordborg

(In [2683]) References #548: Register Demux and Merge as ended

Also delete file items linked with bioassays if the "delete items" option is selected.

Made the import of files more robust by allowing it to overwrite existing files.

Some adjustments to the information table to use the space more efficiently.

comment:21 Changed 5 years ago by Nicklas Nordborg

(In [2728]) References #548: Register Demux and Merge as ended

Display '-' instead of 'null' when values are missing.

Note: See TracTickets for help on using tickets.