Opened 6 years ago

Closed 6 years ago

#511 closed defect (fixed)

Consent information not copied from PreNeo blood registration

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v2.13
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

It seems like registering information from a patient in the following order Blood, Consent, Case fails to copy the consent information from the Blood item to the Case item.

Change History (3)

comment:1 Changed 6 years ago by Nicklas Nordborg

Status: newassigned
Summary: Consent information not copied from blood registrationConsent information not copied from PreNeo blood registration

After investigating this a bit more it seems like the root cause is that the Blood item is a PreNeo blood, and the Case information is from a surgery. There is no case for core biopsies and no blood from PreOp.

When the core biopsy support was implemented in #381, code was added in to ConsentFormServlet [1622] to allow the consent registration wizard to find blood with or without PreNeo annotation. The same change was never made in PersonalRegistrationServlet.

comment:2 Changed 6 years ago by Nicklas Nordborg

(In [2037]) References #511: Consent information not copied from PreNeo? blood registration

The registration wizard will now also check for blood without any special filter for PreNeo or PreOp.

comment:3 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

Added instructions for manually copying consent informatio. See Reggie 2.13 update notes.

Note: See TracTickets for help on using tickets.