Opened 8 years ago

Closed 8 years ago

#387 closed defect (fixed)

The ROOT user doesn't have permission to use several reggie wizards

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: Reggie v2.6
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

The front page of Reggie that list the available wizards is missing several wizards when logged in as ROOT. The cause of this is that the code only checks if the user is a member of the Administrators role or the PatientCurator group. Since the ROOT user is not a member of any the wizards are not displayed.

The workaround is to make the ROOT user a member of the Administrators role.

Change History (1)

comment:1 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [1635]) Fixes #387: The ROOT user doesn't have permission to use several reggie wizards

Note: See TracTickets for help on using tickets.