Opened 7 years ago

Closed 7 years ago

#333 closed task (fixed)

Update to MeV 4.7

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: MeV Launcher v1.8
Component: net.sf.basedb.mev Keywords:
Cc:

Description

They have added support for RNASeq data. Seems to be regular TDMS files with Count, RPKM or FPKM values. The existing TDMS exporter should be able to create the file already. The remaining question is what we have to do to tell MeV what is in the file. Can we do that with the java webstart parameters or can the user select it in the file dialog?

http://www.tm4.org/mev/?q=node/223 http://bioinformatics.oxfordjournals.org/content/early/2011/10/05/bioinformatics.btr490

Attachments (2)

rnaseq-file-loader.png (28.6 KB) - added by Nicklas Nordborg 7 years ago.
The RNASeq file loader in MeV
rnaseq-fpkm-loaded-as-tdms.png (51.8 KB) - added by Nicklas Nordborg 7 years ago.
RNASeq FPKM data loaded with the TDMS file loader

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by Nicklas Nordborg

Milestone: MEV Launcher v1.xMeV Launcher v1.8
Status: newassigned

I have upgraded to 4.7.3 and the FPKM data can be loaded if we use the "tdms" file loader. The "rnaseq" loader gives an error message about "Bad format error: Invalid File format for data type 0. Select valid format" (even when using one of the example RNASeq files from the MeV download). My guess is that the problem is that the "rnaseq" loader has several options in the file open dialog that can't be set from the command line (eg. Data Type, Species, Reference Genome, etc).

I'll move this ticket to 1.8 since it seems that the data can at least be loaded as "tdms". Don't know if downstream analysis will suffer from this or not.

Changed 7 years ago by Nicklas Nordborg

Attachment: rnaseq-file-loader.png added

The RNASeq file loader in MeV

Changed 7 years ago by Nicklas Nordborg

RNASeq FPKM data loaded with the TDMS file loader

comment:2 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [1414]) Fixes #333: Update to MeV 4.7

Note: See TracTickets for help on using tickets.