Opened 9 years ago

Closed 9 years ago

#324 closed defect (fixed)

Problem registering a case for specimen tubes with children

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v1.5
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

  1. Create a specimen tube using the normal reggie naming convention: 12345.1
  2. Create a child extract (lysate): 12345.1.l
  3. Use the personal information registration wizard in reggie to register the case.
  4. As soon as the case number (12345) is entered, an error message is displayed:
The case (12345) was found but it is not associated with any patient. 
This wizard can't be used until that is corrected.

This is obviously not true. The problem seems to be that the wizard thinks that the specimen tube is a case. The query it is using to find cases is basically: find all samples which has a child item with a name matching <case number>.%

The problem is that the name of the lysate matches this. We need to come up with a better search pattern that only matches <case number>.<digits>. We need regular expressions for this and MySQL has support for it so it shouldn't be too difficult once we can figure out the syntax.

Change History (1)

comment:1 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [1366]) Fixes #324: Problem registering a case for specimen tubes with children

Note: See TracTickets for help on using tickets.