Opened 9 years ago

Closed 9 years ago

#323 closed defect (fixed)

Cannot save "Personal information registration" form if no "Sampling date" or "RNA Later date" is entered

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v1.5
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

This ticket replaces #320.

There is a problem saving the "Personal information registration" form when the "Sampling date" and "RNA Later date" fields are emtpy. If there are no date+time values, the "Create" button doesn't work.

There is a workaround... Use 'Tab' (or the mouse) to step through the input fields so that each date+time box is selected and deselected at least once. The "Create" button will now work.

I think the problem is that when the form is loaded all fields starts out in 'invalid' state. Each field is usually validated when it loses the input focus. Empty date+time are considered valid by the validation function, but this is only called when:

  1. There are date+time values when the form is loaded
  2. The date+time fields are deselected

The solution is that the "Sampling date" and "RNA Later date" should start in 'valid' state when the form is loaded.

Change History (1)

comment:1 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [1367]) Fixes #323: Cannot save "Personal information registration" form if no "Sampling date" or "RNA Later date" is entered

Note: See TracTickets for help on using tickets.