#1213 closed defect (fixed)

Firefox fails to open some Print dialogs

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: Reggie v4.25
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

There are several places in Reggie were a "Print" button should open a printable version of a lab protocol. This seems to not work at all times, but an empty window is displayed. See the attached image for an example from the "Pick lysates for re-extraction" wizard.

There are some strange things:

  • The DOM inspector in the developer tools indicates that the document is there.
  • The request log indicates that images, etc. are fetched which seem to indicate that the document is parsed
  • None of the toolbar buttons are working, except "Refresh" that simply reloads the same empty page.
  • Dragging the dialog to another window suddenly display the document

Tested with Firefox 71 on two different computers but the problem is only present on one of them. This could be something that is caused by some extension...

Attachments (1)

empty-print-dialog.png (11.6 KB) - added by Nicklas Nordborg 11 months ago.

Download all attachments as: .zip

Change History (4)

Changed 11 months ago by Nicklas Nordborg

Attachment: empty-print-dialog.png added

comment:1 Changed 11 months ago by Nicklas Nordborg

I found the 'dom.disable_window_open_feature.location' setting in about:config to be different. On the computer with the problem this was changed to 'false' (the default is true). Changing it back to 'true' makes the problem disappear. The problem also seems to disappear if the window is opened with 'toolbar=yes,location=yes' options (javascript in Reggie). The current options are 'toolbar=yes,location=no'.

comment:2 Changed 11 months ago by Nicklas Nordborg

The nice thing with having dom.disable_window_open_feature.location=false is that the location field is not visible in regular popup dialogs (they usually also have 'toolbar=no,location=no') and this seems to work. But in the "Print" dialog we really want the toolbar or it is not possible to access the actual "Print" function in Firefox.

comment:3 Changed 11 months ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 5780:

Fixes #1213: Firefox fails to open some Print dialogs

The dialogs are now opened with toolbar=yes,location=yes and this should hopefully work no matter what the dom.disable_window_open_feature.location setting is.

Note: See TracTickets for help on using tickets.