Opened 20 months ago

Closed 20 months ago

Last modified 16 months ago

#1134 closed task (fixed)

Implement an "Activity log"

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: Reggie v4.23
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

It would be nice to display some more information about what is going on in the lab and on the computers the Reggie front page.

While we are re-designing the front page (#1133) we could maybe keep three columns as before and in one of them display a list of the most recent "activities". For example:

Today
13:35 12 samples has been extracted
09:22 6 specimen tubes has been registered
01:25 Sequencing of FlowCell555 completed successfully

Yesterday
16:56 Sequencing of FlowCell555 has started
14:25 Reggie was updated to version 4.23

It should be possible to merge entries of the same type that are happening on the same day. For example, if registering another specimen tube the count above would increase to '7' and the timestamp updated.

The log should be limited to some specific number (or age) of events.

The log need to survive server re-starts.

Change History (18)

comment:1 Changed 20 months ago by Nicklas Nordborg

Component: not classifiednet.sf.basedb.reggie
Milestone: Reggie v4.23
Owner: changed from Jari Häkkinen to Nicklas Nordborg
Status: newaccepted
Type: Requesttask

comment:2 Changed 20 months ago by Nicklas Nordborg

In 5376:

References #1134: Implement an "Activity log"

Added an activity log service. Basic functionality is in place. Activities can be logged. Activities of the same type on the same day are merged to a single log entry. Log entries are saved to the static cache automatically, and reloaded if the server (or Reggie) re-starts.

The specimen tube and storage box registration have been used for testing.

The activity log is served together with the "counter" statistics and displayed in the rightmost column on the front page.

comment:3 Changed 20 months ago by Nicklas Nordborg

In 5377:

References #1134: Implement an "Activity log"

Added activity logging for the installation wizard, extraction, rna/dna normalization and partion wizards.

comment:4 Changed 20 months ago by Nicklas Nordborg

In 5378:

References #1134: Implement an "Activity log"

Minor re-organization on the index page to prevent the "Case summary" search box from scrolling.

comment:5 Changed 20 months ago by Nicklas Nordborg

In 5379:

References #1134: Implement an "Activity log"

Added activity logging for the RNAQC wizards.

comment:6 Changed 20 months ago by Nicklas Nordborg

In 5380:

References #1134: Implement an "Activity log"

Implemented filtering function for removing older activited from the log.

comment:7 Changed 20 months ago by Nicklas Nordborg

In 5381:

References #1134: Implement an "Activity log"

Added activity logging for the histology wizards and changed other messages to be more alike.

comment:8 Changed 20 months ago by Nicklas Nordborg

In 5382:

References #1134: Implement an "Activity log"

Added activity logging for library preparation, pooling and sequencing wizards.

comment:9 Changed 20 months ago by Nicklas Nordborg

In 5384:

References #1134: Implement an "Activity log"

Added ActivityDef for easier and better generation of messages for activities. Existing code for creating activity events have been updated.

Added activities for secondary analysis.

comment:10 Changed 20 months ago by Nicklas Nordborg

In 5385:

References #1134: Implement an "Activity log"

Reading and saving the activity log should now be more stable in case there are some problems.

comment:11 Changed 20 months ago by Nicklas Nordborg

In 5387:

References #1134: Implement an "Activity log"

Added activity logging for referral form and patient registration and INCA import.

comment:12 Changed 20 months ago by Nicklas Nordborg

In 5388:

References #1134: Implement an "Activity log"

Added an entry "Nothing yet" to the activity log if it is empty or if the first entry is not an activity for "Today".

comment:13 Changed 20 months ago by Nicklas Nordborg

Resolution: fixed
Status: acceptedclosed

comment:14 Changed 19 months ago by Nicklas Nordborg

In 5404:

References #1134: Implement an "Activity log"

Added support for getting the activity log as an RSS feed.

comment:15 Changed 19 months ago by Nicklas Nordborg

In 5412:

References #1134: Implement an "Activity log"

Found a commit() call that was disabled.

comment:16 Changed 19 months ago by Nicklas Nordborg

In 5421:

References #1134: Implement an "Activity log"

Update the activity log to also store the current user and active project. This should make it possible to have different activity log for different projects (if we ever need that!).

The RSS feed that was implemented in [5404] now include an <author> tag with the user name.

comment:17 Changed 19 months ago by Nicklas Nordborg

In 5422:

References #1134: Implement an "Activity log"

Use the new methods implemented in http://base.thep.lu.se/ticket/2176 to get the name of the user and active project.

comment:18 Changed 16 months ago by Nicklas Nordborg

In [5580] (manually copied here since commit comment used incorrect ticket number):

References #1134: Implement an "Activity log"

Added name of pipeline to the "demux confirmed" event. Example:

Demux confirmed for 16 RNAseq libraries
Note: See TracTickets for help on using tickets.