Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#1071 closed defect (fixed)

Installation wizard doesn't show error message

Reported by: Nicklas Nordborg Owned by:
Priority: major Milestone: Relax v1.4
Component: net.sf.basedb.relax Keywords:
Cc:

Description

If there is an error (that can't be fixed) in the installation wizard and error message should be displayed. The problem is that the HTML/CSS is placing the error message below the table with detailed information so that it is not visible.

There is also a problem that fixable errors use the same icon as un-fixable errors so if there is a mix it is very hard know which errors need to be manually fixed and which ones that can be automatically fixed later.

Change History (5)

comment:1 Changed 2 years ago by Nicklas Nordborg

(In [5041]) References #1071: Installation wizard doesn't show error message

The error message should now be located at the bottom of the screen.

comment:2 Changed 2 years ago by Nicklas Nordborg

(In [5042]) References #1071: Installation wizard doesn't show error message

Changed the icon for "missing" item to a warning icon. This makes more sense since that is something that can be automatically fixed.

comment:3 Changed 2 years ago by Nicklas Nordborg

(In [5043]) References #1071: Installation wizard doesn't show error message

The "Fix items" button is now displayed when there are items that can be fixed even if there is an error or not.

comment:4 Changed 2 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

comment:5 Changed 22 months ago by Nicklas Nordborg

(In [5122]) References #1071: Installation wizard doesn't show error message

Fixed a problem where the installation wizard displayed "All checks passed" at the same time as a button "Create missing items".

Note: See TracTickets for help on using tickets.