Opened 2 months ago

Closed 2 months ago

#1059 closed defect (fixed)

NullPointerException when running the Genotype quality control wizard and no patient has been registered for a specimen

Reported by: nicklas Owned by: nicklas
Priority: minor Milestone: Reggie v4.19
Component: net.sf.basedb.reggie Keywords:
Cc:

Description

Knowing if two samples are from the same or from different patients is vital when comparing the genotypes for two alignments.

In case the referral form registration has not been completed for all received specimen, it may happen that there is no patient information for some of the alignments. This causes a NullPointerException since the code assumes that a patient exists for all specimen.

This need to be handled better so that the operator get some information about this. It should not be possible to select alignments until they have patient information.

Change History (1)

comment:1 Changed 2 months ago by nicklas

  • Resolution set to fixed
  • Status changed from new to closed

(In [4925]) Fixes #1059: NullPointerException? when running the Genotype quality control wizard and no patient has been registered for a specimen

Alignments without patient information is no longer selecteable in the list. A warning is also displayed that must be confirmed before the wizard is allowed to the next step.

It is still possible to manually select alignments without patient information. In this case, the check is started but the condition is catched early and an error message is displayed that explains what is wrong.

Note: See TracTickets for help on using tickets.